← Vulnerability database

CVE-2026-115915

Critical
9.8 CVSS v3.1
Published
Oct 26, 2026
Updated
Oct 28, 2026
Vendor
Vllm
Affected versions
See affected products
Weakness
CWE-20, CWE-183

Summary

vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process’s privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.

Severity

Critical (9.8)

CVSS vector

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Affected products

  • Vllm Vllm >= 0.30.0, < 0.32.0

Exploitation status

Unknown

Technical details

Technical analysis has not been written for this record yet.

Mitigation & remediation

Follow the vendor advisory linked below for patches and workarounds.

References

Source NIST NVD
Last syncedOct 28, 2026 19:45 UTC
Reviewed Oct 28, 2026
Page updatedOct 29, 2026