CVE-2026-105134
CriticalAhsay AhsayCBS Command Injection Vulnerability
- Published
- Oct 4, 2026
- Updated
- Oct 26, 2026
- Vendor
- Ahsay
- Affected versions
- See affected products
- Weakness
- CWE-77, CWE-78
Summary
A flaw has been found in Ahsay AhsayCBS up to 9.15.2.69/10.3.4.44. This vulnerability affects unknown code of the file /rps/api/json/UpdateReceivers.do of the component Replication Receiver. Executing a manipulation of the argument random can lead to os command injection. It is possible to launch the attack remotely. The exploit has been published and may be used. Upgrading to version 9.15.2.70 and 10.3.4.45 is able to resolve this issue. Upgrading the affected component is advised. The initial patch did not fix the security vulnerability properly. An update of the CVE entry to reflect this became necessary.
Severity
Critical (10.0)CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
CVSS v4.0 (10.0)
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:A/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Affected products
- Ahsay Cloud Backup Suite < 9.15.2.70
- Ahsay Cloud Backup Suite >= 10.1.0, < 10.3.4.45
Exploitation status
Actively exploited
Listed in the CISA Known Exploited Vulnerabilities catalog on Oct 14, 2026. Federal remediation due: Oct 17, 2026.
Technical details
Technical analysis has not been written for this record yet.
Mitigation & remediation
- Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.
