← Vulnerability database

CVE-2026-102828

Critical
9.8 CVSS v3.1 CVSS v4.0: 9.2
Published
Sep 29, 2026
Updated
Oct 8, 2026
Vendor
Simple-git Project
Affected versions
See affected products
Weakness
CWE-78, CWE-184

Summary

simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. From 3.15.0 until 4.0.1, the default blockUnsafeOperationsPlugin does not classify trailer..cmd as unsafe configuration. An application that passes attacker-controlled values through SimpleGitOptions.config or inline -c arguments can therefore allow Git to invoke an attacker-selected shell command when git interpret-trailers processes the configured trailer. The command executes with the operating-system identity and permissions of the Node.js process. This issue is fixed in 4.0.1.

Severity

Critical (9.8)

CVSS vector

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

CVSS v4.0 (9.2)

CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

Affected products

  • Simple-git Project Simple-git >= 3.15.0, < 4.0.1

Exploitation status

Unknown

Technical details

Technical analysis has not been written for this record yet.

Mitigation & remediation

Follow the vendor advisory linked below for patches and workarounds.

References

Source NIST NVD
Last syncedOct 28, 2026 19:45 UTC
Reviewed Oct 28, 2026
Page updatedOct 29, 2026